• Jon

    Hello! A quick tip on how to fade audio with Templater via an expression. Since Templater can dynamically swap a wide variety of media sources of varying lengths, you can’t count on keyframes to be able to accommodate the variation of durations for consistent fade-outs of audio tracks. Here’s a sample of how to do that. Apply this expression to the Audio Levels.

    fadeTime = 30; //frames for fade
    audio.audioLevelsMin = -48; 
    audio.audioLevelsMax = audio.audioLevels[0];
    layerDuration = outPoint - inPoint;
    singleFrame = thisComp.frameDuration;
    animateOut = linear(time, (outPoint - framesToTime(fadeTime+1)), (outPoint-singleFrame), audio.audioLevelsMax, audio.audioLevelsMin);
    [animateOut,animateOut];
    

    In this example, the expression takes the audio level you’ve set and fades to -48 db over 30 frames (assuming 30fps composition, that is 1 second).

    posted in Templates read more
  • Jon

    @cmoyer

    Testing the collapse transformations issue, it looks like any effect (not limited to the Templater Settings effect) that you apply to that precomp will break or change your collapse transformation in unexpected ways. There is something weird happening in the way that AE applies effects to collapsed precomps. I’m not entirely sure of a way around this issue.

    From Adobe’s help (with my highlights):

    “When a closed mask (with mask mode other than None), a layer style, or an effect is applied to a nested composition with collapsed transformations, the layers in the nested composition are first rendered on their own, then masks and effects are applied, and then the result is composited into the main composition. This rendering order means that the blending modes of the nested layers are not applied to any underlying layers in the main composition, and that 3D layers above and below the collapsed layer cannot intersect or cast shadows on each other.”

    posted in Templates read more
  • Jon

    @rens Unfortunately AE’s API access to the character palette is extremely limited, so your best bet would be to create a pre-job script that copies your master AEP and opens the project in AE, to run Templater off of the copy instead of the master. This will leave your master always untouched. In the instance that a missing glyph breaks one project, it won’t break all of the subsequent projects. You could also try running an ExtendScript that updates the font on that layer on the post-update event every time, but I think that could be more problematic.

    Bot events.

    posted in Batch Output read more
  • Jon

    @zen169

    Hi Jean-Michel, we are working on adding a new feature that will make this easier, but in the meantime, if you want to access a value from your data, you need to connect the value to a text layer, then enable expressions for the slider and connect the slider to the sourceText value of the text layer, and wrap it in parseInt() to convert the string to an integer that the slider control effect can read. It would look like:

    parseInt(comp("your comp name").layer("your text layer name").text.sourceText)
    

    posted in Google Sheets read more
  • Jon

    @v_47 Hello!

    You are very close to getting it working. Underscores are reserved characters for Google Sheets, so using them in the titles of column headings won’t work. If you remove those or replace them with a dash, that should resolve the issue. There are a few other caveats about Google Sheets than you can read about in the notes here.

    posted in Templates read more
  • Jon

    Hi @Rens In After Effects, try doing Edit > Purge > All media and disk cache. It’s possible that there were old cached frames that still had the watermark, or perhaps there was a moment before the Templater license check happened where some frames loaded with the watermark. Let us know whether that resolves the issue.

    posted in Environments read more
  • Jon

    If you are interested in setting up your dynamic layers to accommodate both portrait and landscape footage (photos or videos) within a composition, here’s how to do that:

    We will assume that you are creating a “square” precomp, and that you want the footage to fill the composition in either direction and to letterbox or pillarbox that footage appropriately.

    First, the most important thing is that rather than having the composition be a perfect square, you need to make sure that your width is at least 1px longer than the height. So rather than 800 px x 800 px, it would need to be at a minimum 801 px x 800 px. This is going to be true even if you aren’t going for a square precomp. The letterbox/pillarbox will not work if the comp is taller than it is wide.

    Add the Templater Settings effect to your desired footage layer. In the Templater Settings effect, in the “Layout” section, you have the option to set a “Scale factor”- you’ll want to set that to 100%. In the “Alignment” section there is an option “initialize to center”- make sure to enable that.

    That should be all you need to accommodate footage sources of different dimensions.

    posted in Templates read more
  • Jon

    @bluesummitrealty Were you able to resolve your issue?

    posted in Templates read more
  • Jon

    @bluesummitrealty How is that date being injected into that text layer? Is there an expression driving it? Is it a spreasheet today() value? Are there keyframes on that text layer or Source Text property? It could also be a cache issue of some sort.

    posted in Templates read more
  • Jon

    @raphster said in How to keep templater from changing layer visibility?:

    Found a workaround by importing text to a dummy layer at the bottom of the comp from which the track matte pulls the source text.

    You can also precomp your text layer (move all attributes into the comp), and use the precomp as your track matte.

    posted in Templates read more

Looks like your connection to Dataclay | Forums was lost, please wait while we try to reconnect.